Please login or register.

Login with username, password and session length

Author Topic: Amp 'Popping' on switch off  (Read 5594 times)

Offline Andi

  • Full Member
  • ***
  • Posts: 244
    • http://www.monkeyfx.co.uk
Amp 'Popping' on switch off
« Reply #15 on: August 14, 2007, 09:41:06 AM »
Hmm. My Laney LC15 pops when you turn off with the power switch, but not if you pull the plug. On the Laney it's a common issue (so I've been told) and is down to arcing in the mains switch (as Paul suggested originally - I suspected he was right). But if it still pops then I think it's likely something else somewhere. At this point I'm out of my knowledge zone so I'll defer to others - hopefully I've helped a bit.
 

Amp 'Popping' on switch off

Offline Gixxernutter

  • Full Member
  • ***
  • Posts: 230
    • http://www.joe-schmo.com
Amp 'Popping' on switch off
« Reply #16 on: August 14, 2007, 10:07:39 AM »
Cheers Andi, all your suggestions have made sense to me, and have helped to narrow down the problem.
Fly Classic 03 w/Bare Knuckle Crawlers
Cornford MK50II
Marshall 4X12 Vintage 30's/Greenbacks
http://www.joe-schmo.com

Re: Amp 'Popping' on switch off

Offline ampdoc

  • Newbie
  • *
  • Posts: 1
Re: Amp 'Popping' on switch off
« Reply #17 on: May 24, 2014, 07:37:34 PM »
ANYBODY OUT THERE?

I ran down this thread while trying to fine a schematic of the TE Twin Stereo Quad Chorus amplifier.  It is shown as posted in the earlier discussion, but the link is not active any longer.

Anyone got this to share?

ampdoc